Revolution 2.3.6 — UI Improvements & Stability

This Revolution 2.3.6 patch release includes incremental improvements to the Manager UI, as well as a number of fixes for stability and security.

By YJ Tso
August 18, 2015
Revolution 2.3.6 — UI Improvements & Stability

This Revolution 2.3.6 patch release includes incremental improvements to the Manager UI, as well as a number of fixes for stability and security.

Here are some of the changes in Revo 2.3.6:

  • Those using the traditional install can now disable on-the-fly compression.
  • A potential XSS vector was closed.
  • Some category dropdowns were missing pagination—now see them in all their paginated glory.
  • Setup Options window has been taught to be more flexible.
  • Improved experience of Image TVs, and thumbnails, in the Manager.
  • Hunting for version info is a thing of the past. Hover over the MODX Logo and all shall be clear again.
  • View the Revo 2.3.6 change log for full details.

Let’s take the time to thank the individual contributors to this release (in no particular order): BobRay, cedwardsmedia, Jako, sottwell, sitex-pro, rtripault, argnist, bertoost, Fi1osof, bezumkin, mindeffects, inreti, and theboxer.

We cannot stress how important it is to be running the most current version of MODX. We are always improving security and staying in the habit of regular upgrades dramatically reduces the chance of your site getting hacked.

Here’s what you need to get started or upgrade to MODX Revolution 2.3.6:

Revolution 2.3 was a significant release. If you're not yet using it here's what you're missing out on.

MODX is only as good as it is because of many individual community members and users that take the time to report issues and request new features. Make sure you read the documentation, post feedback and share your successes in the MODX community forums.

On behalf of the entire MODX Team,
Thank-you!

IMPORTANT UPDATE: For a very short period tonight, the install packages contained a flaw that has since been fixed. Please ensure you discard any downloads from before 04:42 UTC on August 19, 2015. If you installed one of these early packages, it's important that you download the new package and upgrade again.