PassChecker 1.0.3-pl

PassChecker 1.0.3-pl

Released Nov 15, 2018 by census

MODX package for checking compromised passwords against HIBP Passwords.

After a user signs in their password will be checked against known breaches by sending the first five characters of a sha1 hash to the Passwords API. The user will be notified if the password is found. This creates awareness and provides a easy way of changing the password from within the pop-up. 

Download 53kb (32 downloads)
Downloads: 134
License: MIT
Requires Revolution 2.4.x or greater
Supports mysql

- Fixed 'Passchecker plugin has failed' log

Installation Instructions

After installing the package will run automatically. 

System Settings:

  • Notify threshold: Optional setting for a threshold before a user will be notified.
  • Require password change: Option for requiring a password change. This will prevent a user from ignoring the message.

- Fixed 'Passchecker plugin has failed' log (PWNED-14)

Version Released Author Downloads
2 Versions 1 Contributors 134 Downloads
1.0.2-pl Jun, 07 2018 census 102